Make compatible with VS Express 2012?

Feb 10, 2013 at 12:41 PM
The current version of ClearScript is not compatible with VS Express 2012, and I think that's a shame for an excellent project like this :)

As far as I can tell it involves very few changes to make it compatible:

V8Update should use msbuild to build the project instead of devenv:
msbuild /p:Configuration="%mode%" /p:Platform="x64" tools\gyp\v8.sln >build.log
Any references to the ATL should be removed since this is not part of VS Express. This shouldn't be too difficult because it seems to only really used in the line:
m_DebugAgentEnabled = Debug::EnableAgent(CW2A(pName), debugPort);
in the V8ContextImpl.cpp file.

Would it be possible for you to implement the changes to make it compatible?
Coordinator
Feb 10, 2013 at 2:13 PM
Hello MrIze,

Thank you for bringing this to our attention! We are looking into it and will send an update ASAP.

Cheers!
Coordinator
Feb 11, 2013 at 2:57 PM
We are tracking this issue here.
Coordinator
Feb 11, 2013 at 5:54 PM
We've posted an update that fixes this issue. Thanks for your help!
Feb 11, 2013 at 9:39 PM
Wow that was fast. Thank you so much :)
Coordinator
Feb 11, 2013 at 10:29 PM
Thank you for reporting and helping us debug this issue. You did most of the work!