This project has moved and is read-only. For the latest updates, please go here.

ClearScript & Azure, Can't find ClearScriptV8-32.dll, ClearScriptV8-64.dll, v8-ia32.dll, v8-x64.dll

Sep 24, 2013 at 3:03 AM
Hey guys,

Sorry for coming back so soon, but I just wanted to know if you guys tried to deploy ClearScript.v8 to Windows Azure embeded in a Cloud Service.

I am getting this error:
Cannot load V8 interface assembly; verify that the following files are installed with your application: ClearScriptV8-32.dll, ClearScriptV8-64.dll, v8-ia32.dll, v8-x64.dll
Any hints on this one?
Thanks a lot!

Sep 24, 2013 at 4:21 AM
Hi Hudson,

What are you deploying to Windows Azure? If it's a web application, the files listed in the error message should be added as content files. For a desktop or console application, they should be installed side-by-side with the executable. Please tell us more and we'll try to get this resolved for you.

Sep 24, 2013 at 5:47 AM
Hi dude,

It's a WebRole for a Cloud Service, indeed.

I have added all those assemblies as Content to the root of the WebApplication, with no luck.

Any other ideas?

Sep 24, 2013 at 12:05 PM
Hi Hudson,

Can you reproduce this in Development Fabric? Or does it only happen in an actual deployed Azure instance?

Sep 24, 2013 at 12:30 PM
Sharp question: yes, I did run it in the Development Fabric and it worked perfectly.
Just happens on the deployed Azure instance.

Sep 24, 2013 at 2:43 PM
Thanks, Hudson. We're tracking this issue here.
Sep 24, 2013 at 9:54 PM
Hey, guys.

Just to let you know that I have updated the issue with some more intel that I gathered.

Thanks very much,
Sep 25, 2013 at 3:40 PM
Hi Hudson,

With your project configured as before (ClearScript's V8 assemblies installed as content files at the root of your web application), please try the following:
Please let us know if this worked for you.
Sep 25, 2013 at 4:52 PM
Will do it ASAP and I will get back at you.
Hudson Mendes
Fábrica Agile & Sustentação
De: ClearScript
Enviado: ‎quarta-feira‎, ‎25‎ de ‎setembro‎ de ‎2013 ‎11‎:‎41
Para: [email removed]

From: ClearScript

Hi Hudson,

With your project configured as before (ClearScript's V8 assemblies installed as content files at the root of your web application), please try the following:
Please let us know if this worked for you.
Sep 30, 2013 at 4:48 PM
Hudson, do you have an update? We cannot reproduce any issue as long as the right set of C++ libraries is installed on the Azure instance. Note that if you wish to run Debug code on the instance you must install the debug libraries, which are not redistributable but installed with Visual Studio. Additional information here.
Sep 30, 2013 at 5:10 PM
Hi ClearScript,

I am testing this and returning to you TODAY about it.

Apologise for the wait.


Oct 22, 2013 at 3:00 AM
Hey guys,

I do apologise for not replying in time, but thing got a little mad around here.

Responding to our experiment: yes you guys were right!

I have installed the VC++ Redist for VS 2012 and it worked just like a charm.

That proves the need for the dependencies.

I am now trying to make my VC++ Redist for VS 2012 part of my continuous deployment system, scripting for it to be automatically installed.

The related issue was marked as resolved and it turns out to be right: beucase it did work in the windows azure machine following your instructions.

Thanks very much for all the help.
Oct 22, 2013 at 3:19 AM
Thanks for getting back to us, Hudson! It's great to know that your issue has been resolved.
Apr 28, 2014 at 1:51 PM

i am having the same problem with a web aplication running in IIS8 on windows server 2012 x64 standard.

any ideas ? this is really urgent .

thank you in advance .
Apr 28, 2014 at 10:17 PM
Edited Apr 29, 2014 at 4:14 AM
Hi scharada,

We have a pending change that improves error reporting for V8 deployment issues. Our plan was to bundle it with the next point release, but that's taking a while, so we'll post it on its own within the next day or so.

This change will allow you to see the specific errors encountered during the V8 loading procedure, and should give you a pretty good idea about what's going on in your deployment.


Update: The error reporting enhancement is now available. Please give it a try when you get a chance.